<-- previous page     Table of Contents    Index    next page -->

RUNNING MUP

There are two basic ways to run Mup: directly from a command line or via the Mupmate program. You can use either approach, or switch between them as you wish. The Mupmate program just provides a more menu-driven environment on top of the Mup program itself.

You can create a Mup file using any ordinary text editor, and then run the Mup program on the file you created. On Windows, Notepad is a typical editor choice, and on Linux, editors like vim and emacs are commonly used, but pretty much any text editor (not word processor) can be used. Many people, however, prefer to be able to edit, display, and play from a single integrated and more graphical interface, and for them, a helper program called "Mupmate" is provided. The Mupmate program helps lead you through some of the steps, and you can easily access this User's Guide from its Help menu.

Mupmate

Mupmate is currently only supported on Microsoft Windows, Apple Mac OS X, and Linux. Since the source code is available, and it is based on the cross-platform FLTK toolkit, it would probably be fairly easy to make it run on any system supported by FLTK.

Once you have installed Mup and Mupmate on Windows, double clicking a .mup file in Windows Explorer will run Mupmate on that file. Or, you can run Mupmate by going to the Start menu, and choosing Programs, then Arkkra, and then Mupmate. If you would like an icon on the desktop, you can create one by right clicking the Mupmate choice in the Arkkra menu, choosing "copy", right clicking somewhere on the desktop, and choosing "paste".

On Linux, you can just type the mupmate command in a terminal window, optionally followed by the name of a Mup input file. Or you can add mupmate to your favorite window manager's menus.

On Mac OS X, you can double-click on the MupMate.app in Finder. You should also be able to double-click any file with a .mup suffix, which should then run Mupmate on that file. For setting paths in the Preferences, several "magic" variables are set automatically, if you have not already set them to something else. $APPL is set to the top of the application directory hierarchy. $RSRC is effectively set to $APPL/MupMate.app/Contents/Resources. $HOME is set to your home directory. $SUPP is set to your applications support folder (which is typically $HOME/Library/Application Support). $DOCS is set to your document folder (which is typically $HOME/Documents).

Mupmate provides five top level menus: File, Edit, Run, Config, and Help. The File menu provides commands for opening new files and saving the file you are working on, as well as exiting the program. The Edit menu provides the kinds of things you would expect in a editor: commands to find a pattern, or find and replace; to select text; to copy, cut, and paste; to go to a specific line; and to undo the previous operation, if you make a mistake or change your mind. The Run menu lets you set runtime options, and then run the Mup program on your input in various ways. You can either just generate a PostScript or MIDI file, or display the PostScript or play the MIDI. The Config menu lets you specify what application program you want to use to view PostScript files and which you want to use to play MIDI files, and well as specify locations for other Mup files. Mupmate will try to find reasonable default values, but you may want to check that they are what you want, and tweak them if they aren't. For paths, you can include environment variables to be expanded, by giving their name preceded by a dollar sign. A tilde by itself will be expanded to your home directory, whereas a tilde followed by the name of a user will be expanded to that user's home directory. The Help menu lets you browse this User's Guide, view some startup hints, view the Mup license, or see the current version number of Mup and Mupmate.

Mupmate does not directly provide a print facility. Almost any PostScript viewer already provides this ability, so you can simply select "Display" from the Run menu and use the viewer's print capabilities. Alternately you can use "Write PostScript File" from the Run menu to create a PostScript file that you can print as you would any other PostScript file.


   <-- previous page    Table of Contents    Index    next page -->